IT天空

 找回密码
 加入我们

手机号码,快捷登录

搜索

[求助] Win10需要装.net3.5么

[复制链接]
hashiqi 发表于 2020-1-18 23:46:52 | 显示全部楼层 |阅读模式

IT天空 定制版高速U盘 64G/128G/256G | 固态U盘 256G Pro/512G Pro
Win10自带的.net框架现在已经是4.8了
WIN10有必要装.net3.5么?
程序在基于.net开发的时候会考虑尽可能多的兼容,可能会采用.net3.5 2.0来开发!


想知道的是高版本.net框架兼容低版本框架程序么?


现在封装win10需要预装.net3.5框架么?


因为我发现,只有高版本框架程序在低版本.net上无法运行,没发现过低版本.net程序没法在高版本上运行。就算是.net2.0写的程序,在win10.net4.8上依旧可以运行。


所以,封装win10有必要预装.net3.5么,或者说运行哪类程序有明确要求必须电脑上有.net3.5么(这类程序应该有自带.net包如果需要安装时应该会自动装上吧?)


最近访问 头像模式 列表模式
 楼主| hashiqi 发表于 2020-1-18 23:48:12 | 显示全部楼层

活跃 978| 技术 10| 互助 10| 钻石 150

来个真正了解系统及软件程序的大神给详细解答下,纠结了好久了!!!!万分感谢!提前祝新年快乐!
magicgenius 发表于 2020-1-19 08:38:45 | 显示全部楼层

活跃 49727| 技术 68| 互助 78| 钻石 520

.net 3.5 sp1向下兼容(其实是包含),.net 4.8向下兼容至4.0,而4.x架构与3.x并不兼容。以前很多程序是基于3.x及其以下架构的,所以3.5 sp1 和4.x都要有……

点评

我记得以前论坛里哪位大侠说过 ,装CAD2015的时候 net4.6会导致安装失败,必须要用net4.5.这个我没亲测过,所以绝对的兼容是不存在的。  详情 回复 发表于 2020-3-16 12:47
了解了,三克油,所以还是有一定必要~  详情 回复 发表于 2020-1-19 14:15
4.x是Win10自带的  详情 回复 发表于 2020-1-19 09:14
itsky2 发表于 2020-1-19 09:14:25 | 显示全部楼层

活跃 26785| 技术 57| 互助 120| 钻石 510

magicgenius 发表于 2020-1-19 08:38
.net 3.5 sp1向下兼容(其实是包含),.net 4.8向下兼容至4.0,而4.x架构与3.x并不兼容。以前很多程序是基 ...

4.x是Win10自带的
天空是个不一样的地方,在这里:
有人品、没技术可以更快的学会技术;
有人品、有技术可以更快成为高手;
没人品、有技术等于0;
没人品、没技术尽早回火星吧。
钱先生 发表于 2020-1-19 09:16:49 | 显示全部楼层

活跃 13146| 技术 0| 互助 0| 钻石 0

建议安装,很多软件还能用到3.5,我封装的时候装了
 楼主| hashiqi 发表于 2020-1-19 14:15:31 | 显示全部楼层

活跃 978| 技术 10| 互助 10| 钻石 150

magicgenius 发表于 2020-1-19 08:38
.net 3.5 sp1向下兼容(其实是包含),.net 4.8向下兼容至4.0,而4.x架构与3.x并不兼容。以前很多程序是基 ...

了解了,三克油,所以还是有一定必要~
Skyfree 发表于 2020-1-21 17:53:17 | 显示全部楼层

活跃 263324| 技术 1408| 互助 1802| 钻石 30914

3.5以及以下,3.5以上,以此为分界,相互不兼容。当年因为这个多少程序员骂微软。。。
tiankong1020 发表于 2020-1-28 14:27:14 | 显示全部楼层

活跃 7138| 技术 0| 互助 0| 钻石 0

有些应用必须3.5
cguo 发表于 2020-3-16 12:47:36 | 显示全部楼层

活跃 1748| 技术 0| 互助 0| 钻石 0

magicgenius 发表于 2020-1-19 08:38
.net 3.5 sp1向下兼容(其实是包含),.net 4.8向下兼容至4.0,而4.x架构与3.x并不兼容。以前很多程序是基 ...

我记得以前论坛里哪位大侠说过 ,装CAD2015的时候 net4.6会导致安装失败,必须要用net4.5.这个我没亲测过,所以绝对的兼容是不存在的。
qq119644533 发表于 3 天前 | 显示全部楼层

活跃 8707| 技术 7| 互助 7| 钻石 100

win10 需要安装.NET3.5.1

NET4.8适用于操作系统平台:
Windows 10,版本:1903(附带)、1809、1803、1709、1703、1607(x86和x64)
Windows 7 SP1(x86和x64)
Windows 8.1(x86和x64)
Windows Server 2019 版本 1809(附带)、Windows Server 2019 版本 1809、Windows Server 版本 1803、Windows Server 版本 1709、Windows Server 2016、Windows Server 2012、Windows Server 2012 R2、Windows Server 2008 R2 SP1
其他信息
服务器安装的其他要求
如果必须执行服务器安装,则除了满足基本要求之外,您的计算机还必须安装以下软件:
Internet 信息服务 (IIS) 版本 6.0 或更高版本。 若要访问 ASP.NET 的功能,则必须在安装 .NET Framework 之前先安装包含最新安全更新的 IIS。 ASP.NET 仅在 Windows XP Professional、Windows Server 2003、Windows Server 2008 和 Windows Server 2008 R2 上受支持。
(推荐)Microsoft Data Access Components 2.8 或更高版本。
注意:大多数用户无需执行服务器安装。 如果您不确定是否执行服务器安装,则执行基本安装即可。
Windows Server 2008 R2 Service Pack 1 服务器核心安装程序
此版本的 Microsoft .NET Framework 4 不支持 Windows Server 2008 和 Windows Server 2008 R2 上的服务器核心角色。 要获取支持 Windows Server 2008 R2 Service Pack 1 上服务器核心角色的 Microsoft .NET Framework 4 版本,请访问用于服务器核心的 Microsoft .NET Framework 4(独立安装程序)
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

hashiqi

978

活跃

10

技术

10

互助
签到任务
最火的业界新闻
  • 微软披露全新高危漏洞:影响所有Windows 10
  • 老外自愧不如!全球App吸金能力最强厂商:
  • 电影院复工首批上映电影公益方式发行 平均
  • 围观罗永浩近照:本人2020年首场电商直播要
  • 比官方宣传还猛!台积电5nm晶体管密度比7nm
  • Redmi K30 Pro真机曝光:“恒星系统”四摄
  • 麒麟820安兔兔跑分曝光:接近麒麟980
  • 超算联盟向COVID-19研究人员开放了十六组超
  • 王思聪又缺钱?旗下熊猫互娱1亿被执行人案
  • [图]华为P40系列规格参数曝光:双打孔3200
炫酷的硬件Show
  • 振华SUPER FLOWER 铜皇450W 铜牌电源
  • 比小更小,Mini-STX装机
  • 华擎X99E-ITX + 银欣ML06 装机记
  • 最强双路泰坦硬管水冷 制作流程
  • 银欣FT02,双路E5工作站
  • 迟到的定制机箱小钢炮清理灰尘
  • 乔思伯UMX1 Plus,小巧的家用综合主机
  • 分体水冷第二弹-Inwin 805 infinity
  • 第一次DIY硬管水冷~~
  • 樱桃MX6.0 青轴 机械键盘 开箱
有趣的美图分享
  • 差点看错了
  • 我不想出去了.....
  • 原来这么扎头发的都是秃头?
  • 闹心的污渍
  • 好男孩
  • 你刚才说剪哪根?
  • 算了,不注册了
  • 凑活一下,还能用
  • 强迫症看完很爽
  • 守纸
关注官方微信
快速回复 返回顶部 返回列表