IT天空

 找回密码
 加入我们

手机号码,快捷登录

搜索

[路由器] 思科路由器配置静态IP上网(实例)

[复制链接]
張兩萬 发表于 2018-11-19 13:54:38 | 显示全部楼层 |阅读模式

这里拓扑就不给大家展示了,直接杀入正题。

比较简单,分清楚NAT进出口就OK。

先交代一下环境:现在有思科路由器一台,联通光纤收发器一个,固定上网(公网)IP地址,网关,DNS等,下边连接二层交换机。

路由器端口连接:外网线接在F0/1  则连接下联设备的F0/0就接在交换机的Trunk口。

下面是NAT配置:
interface FastEthernet0/0                                                        //进入0/0端口。
ip address 192.168.0.1 255.255.255.0                                     //配置IP地址并激活,这也可以起到内网网关的作用。
ip nat inside                                                                         //配置该端口为NAT入口,(外网端口为出口)。

interface FastEthernet0/1                                                       //进入F0/1口。
ip address 10.27.139.139 255.255.255.224                             //配置联通分配的静态IP地址,子网掩码并激活该端口。
ip nat outside                                                                      //配置改端口为NAT出口。

ip route 0.0.0.0 0.0.0.0 10.27.139.130                                    //配置缺省路由,(这个网关也是联通会随静态IP一起分配给你)。

ip nat inside source list 199 interface FastEthernet0/1 overload
access-list 199 permit ip 192.168.0.0 0.0.0.255 any                 //配置ACL允许内网上网的网段。


NAT配置完成后,如果下联设备较多、或者没有可以配置DHCP的服务器或三层交换机的话,我们可以继续在路由器中配置DHCP功能。

DHCP:
ip dhcp pool lan                                                                  //创建一个地址池(lan是地址池的名字,可以随便起,但不能有空格)。
   network 192.168.0.0 255.255.255.0                                   //需要给哪一个网段分配IP就写哪一个网段。
   default-router 192.168.0.1                                                //此网段的网关。
   dns-server xxx.xxx.xxx                                                     //配置DNS(如果不知道运营商DNS的话,可以配置8.8.8.8   114.114.114.114).

如果内不需要把内网所有的ip地址分配出去的话,你可以保留几个地址,留给其他网络设备,比如内网交换机,无线AP。这样的话保留地址的配置是:
ip dhcp excluded-address 192.168.0.1 192.168.0.50
这样就192.168.0.1 到192.168.0.50的地址不会被分配给内网的PC。、



这里需要提一下静态路由的大概理念跟配置:
要访问的网段IP,子网,下一跳端口或IP(没有子网)。


最近访问 头像模式 列表模式
 楼主| 張兩萬 发表于 2018-11-19 14:10:19 | 显示全部楼层

活跃 1014| 技术 0| 互助 0| 钻石 0

gutifa 发表于 2018-11-20 10:00:22 | 显示全部楼层

活跃 29| 技术 0| 互助 0| 钻石 0

{:Q42:
 楼主| 張兩萬 发表于 2018-11-20 10:22:36 | 显示全部楼层

活跃 1014| 技术 0| 互助 0| 钻石 0

441228565 发表于 2018-11-20 13:42:24 | 显示全部楼层

活跃 2| 技术 0| 互助 0| 钻石 0

点评

哇。????  详情 回复 发表于 2018-11-20 16:16
 楼主| 張兩萬 发表于 2018-11-20 16:16:10 | 显示全部楼层

活跃 1014| 技术 0| 互助 0| 钻石 0

LeongH 发表于 2018-12-6 16:45:50 | 显示全部楼层

活跃 473| 技术 0| 互助 0| 钻石 0

路由器端口连接:外网线接在F0/1  则连接下联设备的F0/0就接在交换机的Trunk口。
这个下联的交换机上联口就不应该是Trunk口了吧,如果要是交换机走的是vlan1倒也没有关系。

点评

或者同VLAN就不通Trunk了。  详情 回复 发表于 2018-12-7 09:01
 楼主| 張兩萬 发表于 2018-12-7 09:01:09 | 显示全部楼层

活跃 1014| 技术 0| 互助 0| 钻石 0

LeongH 发表于 2018-12-6 16:45
路由器端口连接:外网线接在F0/1  则连接下联设备的F0/0就接在交换机的Trunk口。
这个下联的交换机上联口 ...

或者同VLAN就不通Trunk了。
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

張兩萬

1014

活跃

0

技术

0

互助
签到任务
最火的业界新闻
  • 全球第一款真无孔手机:魅族zero视频上手
  • 替代懒人支架!雷军演示小米9保护壳背带玩
  • 比米8窄40%!小米9实现3.6mm最美“下巴”:
  • 14nm量产在即 中芯国际12nm工艺也取得突破
  • 小米9下巴照公布:缩短40% 号称最窄
  • Intel即将揭秘第11代核显:10nm Ice Lake年
  • 骁龙855即将量产 大批旗舰智能机在路上
  • 优麒麟 18.04.2 LTS 版本发布
  • 1TB的SSD价格自2018年以来已腰斩,而且还会
  • 雷军称小米9将首发高通855 还强调“真首发
炫酷的硬件Show
  • 振华SUPER FLOWER 铜皇450W 铜牌电源
  • 比小更小,Mini-STX装机
  • 华擎X99E-ITX + 银欣ML06 装机记
  • 最强双路泰坦硬管水冷 制作流程
  • 银欣FT02,双路E5工作站
  • 迟到的定制机箱小钢炮清理灰尘
  • 乔思伯UMX1 Plus,小巧的家用综合主机
  • 分体水冷第二弹-Inwin 805 infinity
  • 第一次DIY硬管水冷~~
  • 樱桃MX6.0 青轴 机械键盘 开箱
有趣的美图分享
  • 要学会偶尔对世界说“去nm的”
  • 这才是真正的土味情话,真乃绝世宝典啊!!
  • 就是嘚瑟
  • 上帝创造这个世界......
  • 这小盆有友小小年纪就背负了不该有的债务
  • 可怜的娃
  • 晚上不吃饭真的能减肥吗?
  • 一个钟表的自白,简直感人肺腑,催人泪下
  • 你以为作为一个鳄鱼容易。
  • 安慰
关注官方微信
快速回复 返回顶部 返回列表